Scheduled for 5 Jun 2025 at 1:00 AM – 5:05 AM
Affects
Oxahost Systems
Under maintenance from 1:00 AM to 5:05 AM
Oxahost Website
Under maintenance from 1:00 AM to 5:05 AM
Completed
5 Jun 2025 at 5:05 AMCompleted
5 Jun 2025 at 5:05 AMMaintenance has completed successfully.
In progress
5 Jun 2025 at 1:00 AMIn progress
5 Jun 2025 at 1:00 AMWe are currently performing an update affecting the client area. All other services remain fully operational. Our team is working to restore access as quickly as possible.
Thank you for your understanding.